SELECT YOUR REGION AND LANGUAGE

UNITED STATES
English
LATIN AMERICA
Español
Português
AUSTRALIA &
NEW ZEALAND

English
JAPAN
Japanese
ASIA PACIFIC
English


CLOSE
SPOT Gen4

SPOT Gen4

SATELLITE GPS MESSENGER

Get Help
Get Help
Documents
Documents
Firmware
Firmware
Videos
Videos

LATEST FIRMWARE

Release Date
10/18/2022
Firmware Version
2.1.2
Firmware Updater Version
2.11.1
Update Firmware >>

SPOT Gen4 Support

Get Help  |  Documents  |  Firmware  |  Videos

SPOT Gen4 Support

General

How do I update my device settings?

The SPOT Gen4 will require a device update or sync when changes are made to the device Tracking Interval, Movement Alert or Dock Mode. When a device settings update/sync or firmware update is available for your device, an orange starburst will appear on your SPOT Account when you are signed-in. Clicking on the starburst will display information containing how and where to download the SPOT Device Updater software (click here to download it directly). 

Connect your SPOT Gen4 to your computer with a micro USB cord (included in the box) and open the software. You will need to enter your device's Auth code (located in the battery compartment of the device) and click submit. The SPOT Device Updater will transfer your new settings from your account to your SPOT device.
 

Need more help?


Contact Us

CALL

Phone support is available Monday - Friday, 24h CST.

Please have your PIN ready when calling.

PIN confirmation is not supported via voice. Please enter your pin on your phone dial-pad.

Your PIN, personal identification number, can be found by logging into My Account and clicking on Settings and Billing.

1 (866) 651-7768

Currently traveling outside of the US?  
1 (985) 327-7511

Click here for Customer Support Chat

Chat support is only available in English.
Service cancellations and payments are not supported via chat.

Chat is available Monday through Friday, from 8:00AM to 5:00PM CST.
Chat support is only available with Chrome, Edge, Firefox and Opera.
JOIN OUR NEWSLETTER
CORPORATE OR GOVERNMENT NEEDS?